By default, you cannot build either Parallel HDF5 with C++ or Parallel HDF5 with the thread-safe feature. You will receive a configure error if you try either of these combinations.

Checks were added to the configure to disallow these combinations, as they are not tested and may fail.

However, the --enable-unsupported configure option enables users to get around these checks at their own risk. (You can actually view the configure file to see where the checks are made.) If the build completes properly and the tests pass, then the installation should be okay.