Page tree

The license could not be verified: License Certificate has expired!

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

 Release Information

Page properties
VersionHDF5 1.12.0
Release Date2020-02-29
Download

Hdf download link
Target/display/support/HDF5+1.12.0#files
LinkTextDownload

Release Notes

Cur page link
TargetAnchorreleasenotes
LinkTextRelease Notes

Additional Release Information:

Cur page link
TargetAnchorplatformstested
LinkTextTested Platforms and Configuration Features

   Software Changes From Release to Release for HDF5-1.12
 New Features in HDF5 Release 1.12
 Newsletter Announcement
 

Cur page link
TargetAnchorknownprob
LinkTextKnown Problems

 

Cur page link
TargetAnchorcompatibility1120
LinkTextAPI Compatibility Report between 1.10.6 vs 1.12.0

Information on Upgrading Applications to 1.12:

Video: Moving Applications from 1.10 to 1.12
 Migrating from HDF5 1.10 to 1.12

 

Hdf rm anchor
AnchorNamefiles
Files

Info

Applications that were created with earlier HDF5 releases may not compile with 1.12 by default.

The API Compatibility Macros in HDF5 allow users to work around this issue. Users can specify a compatibility macro mapping for the version of HDF5 that an application was built with. For example, a 1.10 application can be built with 1.12 using either an application or library mapping as follows:

  • To compile an application built with a version of HDF5 that includes deprecated symbols (the default), make sure to pass -DH5_USE_110_API to the compiler. For example (C), you can specify h5cc -DH5_USE_110_API (autotools) and cmake -DCMAKE_C_FLAGS="-DH5_USE_110_API" (CMake).
  • To build an HDF5 library with the 1.10 APIs you must set DEFAULT_API_VERSION to v110 when configuring. For example, with autotools specify --with-default-api-version=v110 and with CMake set -DDEFAULT_API_VERSION:STRING=v110 in the HDF5options.cmake file when using the CMake source release (CMake-hdf5-1.12.0*).

However, users will not be able to take advantage of some of the new features in 1.12 if using these compatibility mappings.

See the Migrating from HDF5 1.10 to HDF5 1.12 page and video for more information.

Location of Software: https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.12/hdf5-1.12.0/

FileTypeCommentInstall InstructionsMd5 Checksum
hdf5-1.12.0.tar.gz Source release

Unix Gzipped source tar file. 

release_docs/ directory in source hdf5-1.12.0.md5
hdf5-1.12.0.tar.bz2 Source release

Unix Bzipped source tar file. 

release_docs/ directory in source   "
hdf5-1.12.0.zip Source releaseWindows zip filerelease_docs/ directory in source   "
CMake-hdf5-1.12.0.tar.gz CMake source release

File to build HDF5 with CMake (Unix).  See Methods to obtain (below).

Building HDF5 with CMake   "
CMake-hdf5-1.12.0.zip CMake source release File to build HDF5 with CMake on Windows
Building HDF5 with CMake    "
Ready to use BinariesBinary FilePre-built binary distributions for Unix and Windows  
HDF5 PluginsBinary FilePre-built HDF5 plugin distributions for Unix and WindowsInformation on HDF5 Filter Plugins 

 

Anchor
warning
warning

Warning
titleAutotools Builds ONLY

Autotools builds should be configured with the --enable-build-mode=production option to build HDF5 1.12.0 in production mode. Production mode is normally the default for configuring HDF5 software with Autotools, but the default change was overlooked in HDF5 1.12.0. Without the --enable-build-mode=production option, HDF5 1.12.0 configured with Autotools will be built in debug mode with expected performance degradation.

The HDF5 1.12.1 release in late Spring will return the default to production mode.

Anchor
downloadsrc
downloadsrc
Methods to obtain  (gz file)
  • firefox – Downoad file and then run:  gzip <distribution>.tar.gz | tar xzf -
  • chrome –  Download file and then run:  gzip -cd <distribution>.tar.gz | tar xvf -
  • wget – wget https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.N/hdf5-1.N.N/src/<distribution>.tar.gz
                gzip -cd <distribution>.tar.gz | tar xvf -

Hdf rm anchor
AnchorNameplatformstested

Tested Platforms and Configuration Features

NOTE:  HDF5-1.12 requires MPI 3.

Bitbucket Server file
repoSlughdf5
branchIdrefs/tags/hdf5-1_12_0
projectKeyHDFFV
filepathrelease_docs/RELEASE.txt
fileEncodingUS-ASCII
lineStart402
progLangplain
lineEnd519
applicationLink5ac7b370-7412-3c8c-ad20-807a68261336

 

Hdf rm anchor
AnchorNamereleasenotes

Release Notes

Bitbucket Server file
repoSlughdf5
branchIdrefs/tags/hdf5-1_12_0
projectKeyHDFFV
hideHeadertrue
filepathrelease_docs/RELEASE.txt
fileEncodingUS-ASCII
applicationLink5ac7b370-7412-3c8c-ad20-807a68261336

 


Hdf rm anchor
AnchorNamecompatibility1120
HTML
<iframe class="hdf-java-docs" height="800px" width="100%" src="https://bitbucket.hdfgroup.org/pages/HDFFV/hdf5doc/master/browse/html/ADGuide/Compatibility_Report/hdf5-1.12-0-vs-hdf5-1.10.6-interface_compatibility_report.html"></iframe>


Hdf rm anchor
AnchorNameknownprob

Known Problems

Info

There is a problem compiling with the latest nag Fortran compiler, version 7.0. Please use nag version 6.2, instead.

The issue has been fixed in the hdf5_1_12 branch of the HDF5 source code in Bitbucket. If you cannot use version 6.2, please contact The HDF Helpdesk for a patch.